WMI-Fehlermeldung beim Aktualisieren eines HP BIOS

Gelegentlich muss auf Clients-PC's das BIOS aktualisiert werden. Bei HP-Clients läuft das so ab:

1. Packet herunterladen
2. unter Windows ausführen und installieren
3. Neustart – fertig

Das ist normalerweise innert wenigen Minuten erledigt. Wenn jedoch bei der Ausführung des Packetes eine Fehlermeldung betreffend WMI angezeigt wird, gerät der Vorgang ins Stocken:

HPBIOSWMI_1

"Dieses System enthält nicht die notwendige WMI-Unterstützung für diese HPQFlash-Version. Verwenden Sie eine HPQFlash Version unter 4.0."

Das Logfile (C:\SWSETUP\SPxxxxx\HPQFlash\HPQFlash.log) konnte auch keine weiteren Auskünfte geben:

09/07/2012 08:59:19.794  — START NEW HPQFLASH SESSION, HPQFLASH version 4.40.1.1 —
09/07/2012 08:59:19.796  Command line =
09/07/2012 09:00:12.580  WMI BIOS Flash function is not supported on this system.  Program will stop
09/07/2012 09:00:12.584  Exit hpqFlash:  Return Code = 0x103
09/07/2012 09:00:12.586  — END HPQFLASH SESSION —

Auf Anhieb konnte weder in den HP-Forums, noch in der grossen, weiten Internet-Welt eine Lösung gefunden werden. Ein Blogpost auf TechNet (!) leitete mich aber in die richtige Richtung:

"…critical HP service disabled…"

Tatsächlich, der Dienst "HP Software Framework Service" sollte zwar automatisch gestartet werden, war aber beendet. Der Dienst konnte aber auch manuell nicht gestartet werden:

HPBIOSWMI_2

Ein Blick in das Verzeichis, wo der Dienst gemäss Dienstkonfiguration installiert ist, zeigte gähnende Leere.

Nach kurzer Recherche fand ich (diesmal wieder bei HP) ein entsprechendes Softwarepacket "HP Software Framework". Nachdem dieses Packet installiert war, konnte der Dienst "HP Software Framework Service" auch wieder gestartet und das BIOS-Update ausgeführt werden.

Martin Wildi

Über Martin Wildi

Systemtechniker und begeisterter FC Aarau Fan. Befasst sich mit Clientdeployment, Exchange, HyperV und ...Musik. Bekommt die Sorgen und Wünsche der Kunden beim ServiceDesk hautnah mit. In seinem eigenen Heim versucht er, das Multimediavergnügen zu perfektionieren.
  1. Dezember 22, 2016

    bin deinem link gefolgt, kann aber das sw-paket nicht finden.
    habe das problem, dass ich nach neuestem win 10 update auf meinem hp envy x2 11-g040eg zwar die lautsprecher hören kann, aber das microfon nicht funktioniert! hab schon alles probiert, auch im internet schon recherchiert und alles was ich da gefunden hab sind banale einstellungsvorschläge wie z.b. treiber deinstallieren & neu starten … ect. pp! leider hilft mir das nicht wirklich weiter. vor dem update hatte ich für einige zeit eine stabile phase mit win 10, aber jetzt ist nervt das ziemlich, da ich mir das gerät hauptsächlich zugelegt habe um über skype kommunizieren zu können. nun wollte ich bei hp das bios updaten und es kommt die besagte meldung kein wmi vorhanden.

  2. Martin Wildi
    Dezember 23, 2016

    Hallo Albert

    Tut mir leid, dass mein Lösungsweg nicht (mehr) funktioniert. Versuche doch eine aktuelle Version des HP Framework zu installieren. Google sollte dir helfen können :).

    Gruss
    Martin

Kommentar schreiben

*